Debugging audio and MIDI connections to Dev Kit

Per the instructions in “Run Elk on Boards”, I connected a Keith McMillen QuNexus USB-MIDI controller to the Pi Hat, plugged in headphones, started Sushi (I had to add a “&” to the end of the command shown on the webpage), and connected the MIDI ports (16 for the kbd, 128 for Sushi) with aconnect.

I don’t hear anything when I play the keyboard. Are there other debugging tools to confirm that the audio outputs are working, and that the MIDI keyboard messages are being received by Sushi?


I don’t have MIDI running on my board yet because I don’t have a direct USB output MIDI device and my MIDI setup is overly complicated, so I can’t really help with that part yet. But, you can test the audio output to the headphone jack with

sushi -r -c ~/config_files/mda-vst2-configs/config_play_arp_mda_synth.json

Not very exciting, but it did verify that audio out was working on my board.

1 Like

Hi Rick!

In addition to what @NeonSilicon said, which is probably the best way to check if the audio output is working on your board, to debug MIDI messages you can do the following:

  1. Launch aseqdump and connect your MIDI device to it with aconnect. You should see incoming MIDI messages
  2. Launch SUSHI with the --log-level=debug flag. This will turn on MIDI logging among the other things, if MIDI messages are received properly, you should see lines like this in SUSHI’s log file:
[2019-12-14 15:39:56.501] [debug] [alsamidi] Received midi message: [e0 0 3e 0] timestamp: 358983144

Which config / plugin are you testing? With the latest build the MDA JX10 VST2 version can stop outputting sound. We investigate the problem and, although very weird, I’m more surprised that it actually sounds in other configs / setups.

It’s using an old-school Chamberlein State Variable Filter that blows up under certain conditinos. I have the same problem with latest GCC on my X86 Linux machine. We tried several build options for the VST2 version but without any luck so far… interesting that the VST3 version doesn’t seem to exhibit the same problem apparently.

Hi Stefano,

The problem was (indeed) the VST2 version of the MDA synth. I changed the command line for sushi to start up the config from the vst3 folder, and now I am hearing sound when I play the keyboard!


  • Rick

P.S. I used to work with Hal Chamberlin while we were both at Kurzweil Music Systems.

Hi rcohen,
how did you configure “aconnect” and when.
Launching the synth, then “bg”, then “aconnect”, then “fg” or does the “aconnect” has to be written in a config file?

Starting only the VST3 leads only to noise from my output.


Here’s what I did.
After I determined that I was getting no sound, I wrote the note here.

  • I followed the advice of @NeonSilicon to test the audio output with config_play_arp_mda_synth.json, and found that I could hear the arpeggiation. So that meant that the audio path is working.
  • I followed the advice of @Stefano to test the MIDI path using aseqdump. That also worked, so I knew that the MIDI path is working.
  • Finally I tried launching a different synth. I used this command
    $ sushi -r -c ~/config_files/mda-vst3-configs/config_mda_synth.json &

Notice that I used the mda-vst3 folder, not the vst2 folder. Also note that I added the “&” ampersand at the end of the command line.

Then I ran

$ aconnect -l

to list the MIDI connections. Found that my keyboard was at 16 and sushi was at 128. Then I ran

$ aconnect 16 128

to connect MIDI in to out. Next,

$ fg

to bring sushi back to the foreground. Now I had sound when I play my keyboard.

Take care,

  • Rick
1 Like

Hi @NeonSilicon,
thank you for your detailed explanation.
Most things you mentioned I got to work and tested yesterday. The arp example worked for me as well as the aseqdump, displaying my MIDI Data coming from my keyboard. As @Stefano and you wrote there is this error with the VST2 version in the new build, so I tried the VST3.
This version sadly only produces permanent (white)noise.
I´ll give it another try today



I´ve found the mistake.
I only tried, but not described, the HDMI/Keyboard version of interacting.
With SSH everything works as expected.
But only with the VST3 version of the synth like @rcohen mentioned.

Thanks to everyone!!!

Hello @andrakar,

That is strange, because I am using an HDMI monitor/USB keyboard combination, not SSH.

  • Rick

Strangely I wanted to test out my yesterdays setup (HDMI/keyboard) and got no HDMI output.
Today I followed the WIFI suggestions from here and so it no longer runs on HDMI…
But WIFI works !

If I could suggest an addition to the very basic getting started Elk tutorial it would be to add Neonsilicon’s suggestion. Some folks like myself would love to have the simplest of tests without having to hook up a keyboard. I poked around for too long trying to find something to audibly verify my kit after getting everything put together and flashed.
Thank you.

1 Like