No command-line after starting Sushi [solved]

I started Sushi, as described in your tutorial here. I wanted to try the mda-vst2.
Sushi seems to start but the command-line is lost. Further commands do nothing.
I thought “aconnect” to connect a MIDI device should be used after the Sushi start.
I´m running the 0.6.0 image.

Hi @andrakar,

I think what you are seeing is the command not going into the back ground. If you start it with an “&” at the end of the command, it will launch in the background and then hitting return once will get you back the command prompt. Like this,

sushi -r -c ~/config_files/mda-vst2-configs/config_play_arp_mda_synth.json &

You can then use the commands “fg” and “bg” to put the running command into that foreground or background state. A ctrl-z will pause the running command and then you can use the fg and bg commands to move it.

Hi NeonSilicon,
thanks for your quick help. I´ve looked for documentations on this, but found nothing.
I wanted to try the synth. How can I connect and use my MIDI keyboard?
I connected it without Sushi and data is transmitted (tested with aseqdump).

Hi @andrakar,
it is the expected behaviour for a command-line application to “block the command-line” when running. Most other Linux command-line applications for audio work in the same way.

As @NeonSilicon suggested, you can add & to launch SUSHI in the background, or you can open another SSH session, or even better you can use a terminal multiplexer like tmux that we included in the distro.

Which plugin are you trying to run and connect to a MIDI Keyboard? There is an issue with the MDA JX10 VST2 version in this build.

Check also this reply on another thread to see how to debug incoming MIDI in SUSHI.

Hi @Stefano,
thanks for your reply.
I´ve read about the problems with the VST2 version in the new build.
I´ve tested this version and had no sound too.
With the VST3 version I only get (white)noise.

HI @andrakar,
did you try other plugins other than the MDA JX10?

If you want other synths, MDA has “mdaPiano” and “mdaEPiano” which are both not exciting but good for such a test. Otherwise, you can grab one of the community plugins here:

like the OB-Xd synthesizer.

If the issue is confirmed to be the same across plugins, it would be good to see SUSHI’s JSON configuration that you are using and/or other details about your setup. I’m guessing you are trying to connect the headphones output, right?

Hi @Stefano,
I didn´t try other plugins yet. Today I´ll give it a new try.
I´m using the headphone jack.

I´ve found the mistake.
I only tried, but not described, the HDMI/Keyboard version of interacting.
With SSH everything works as expected.
But only with the VST3 version of the synth like @rcohen mentioned.

Thanks to everyone!!!

1 Like