Connmanctl issue

When I run scan wifi, I get the error

Error /net/connman/technology/wifi: Method “Scan” with signature “” on interface ""net.connman.Technology doesn’t exist

Should I upgrade my version of connmanctl? If so, how do we upgrade applications on the pi hat? Has anyone else encountered this issue and if so how did you resolve it?

the issue is not the SW version of connmanctl as it is the same that many other people are using successfully.

I’ve seen it happen sporadically on a few boards, though - and in that case, it was a HW issue on that specific Pi. Do you have a Raspbian image or similar to verify that WiFi is working on your Pi?

Alternatively, have you tried to issue enable wifi inside connmanctl?

I have tried enable wifi inside connmanctl and I get the following error:

“Error wifi: Rejected send message, 2 matched rules; type=“method_call”, sender=”:1.10" (uid=1000 pid= 237 comm=“connmanctl “) interface=“net.connman.Technology” member’SetProperty” error name=”(unset)" requested_reply=“0” destination=“net.connman” (uid=0 pid=175 comm="usr/sbin/connmand -n ")

I will try booting the pi by itself and running connmanctl on it directly

I have a Raspberry Pi 3 Model B made in 2015. I will try to install a raspbian image and seeing whether I can get the connmanctl wifi working on that. However I’m not sure i follow how that would help with the Elk image.

Do you think trying a different Elk Audio OS iso file may be worth trying?

HI @shossa3,

The first thing that I’d try is actually just a plain Raspbian image as I suggested in my first post. If you want to try out a new Elk Audio OS, we just released 0.7.0 (with RPi4 support, too).

Okay thanks Stefano. I think I will take this opportunity to upgrade to a Raspberry Pi 4 and continue testing with it.

I got around this problem altogether by just connecting the board by ethernet, leaving it next to my router, and logging in remotely :slight_smile: Up and running now.