Control sushi on boards?

I’m new to elk/sushi and trying to run it on an Raspby4.

Already I did this steps:

Working with Elk Board — Elk DevKit documentation

And have some problems to get audio output, although sushi and plugins
seem to run with a Hifiberry-hat.

Here seems to be a starting point:
Controlling Sushi using Open Sound Control — Elk DevKit documentation

Is it intended to install open sound control on boards?
How could I elsewise find out, if inputs receive signals?

I have the same results with dmesg
as in this post:
Testing input and output

But other then there I don’t have any output signal with a bypass plugin.

After further reading I found this:
Controlling Sushi using gRPC — Elk DevKit documentation

So should this be the easiest answer to my question, how to find out, if there
is audio input to sushi:
“send and listen to osc messages or gRPC to find out”?

I tried to run a simple bypass plugin.
As start I used the config_empty and added some
additional variables like playing_mode and tempo_sync
to ensure, that missing audio-output is not based on
this configuration.
After using only the bypass pluging and still not having
an output signal, I also added a gain plugin to find out,
if this caused the missing output.

Here is my json-config:

“host_config” : {
“samplerate” : 48000,
“playing_mode”: “playing”,
“tempo_sync”: “internal”
“tracks” : [
“name” : “main”,
“mode” : “stereo”,
“inputs” : [
“engine_bus” : 0,
“track_bus” : 0
“outputs” : [
“engine_bus” : 0,
“track_bus” : 0
“plugins” : [
“uid” : “sushi.testing.passthrough”,
“name” : “passthrough”,
“type” : “internal”
“uid” : “sushi.testing.gain”,
“name” : “gain”,
“type” : “internal”,
“Parameters”: {“gain”:“10”}

"midi" : {
"cc_mappings": [


The result: still no audio output.
When starting sushi there is a small noise on the output, which
seems to ensure, that sushi does try to access the hifi-berry-board.
But still no routing form input to output (also no other
plugins seem to work: I also tested with delay and neuralpi).

Is there maybe a simple script available for input-output-bypass-routing
without sushi? To find out, if it is a sushi-problem?

For example: hifi-berrys advice to test audio output is this:
sudo apt-get install sox
play -n synth sine 1000

Is there something similar on elk without sushi (and without apt-get)?

Here is the sushi.log of my command
sushi -r ~/config_files/config_bp.json # the json file pasted above

GNU nano 5.6 /tmp/sushi.log
[2023-04-21 07:55:03.155] [warning] #############################
[2023-04-21 07:55:03.155] [warning] Started Sushi Logger!
[2023-04-21 07:55:03.155] [warning] #############################
[2023-04-21 07:55:03.282] [info] [main] Setting up Xenomai RASPA frontend
[2023-04-21 07:55:03.291] [info] [jsonconfig] Setting engine sample rate to 48000.0
[2023-04-21 07:55:03.291] [info] [jsonconfig] Setting engine playing mode to playing
[2023-04-21 07:55:03.291] [info] [jsonconfig] Setting engine tempo sync mode to internal
[2023-04-21 07:55:03.292] [info] [engine] Track main successfully added to engine
[2023-04-21 07:55:03.292] [info] [engine] Connected engine input 0 to channel 0 of track “0”
[2023-04-21 07:55:03.292] [info] [engine] Connected engine input 1 to channel 1 of track “0”
[2023-04-21 07:55:03.292] [info] [engine] Connected engine output 0 to channel 0 of track “0”
[2023-04-21 07:55:03.292] [info] [engine] Connected engine output 1 to channel 1 of track “0”
[2023-04-21 07:55:03.293] [info] [jsonconfig] Successfully configured engine with tracks in JSON config file “/home/mind/config_files/config_bp.json”
[2023-04-21 07:55:03.294] [info] [jsonconfig] Config file does not have CV/Gate definitions
[2023-04-21 07:55:03.295] [info] [jsonconfig] Config file does not have any Event definitions
[2023-04-21 07:55:03.295] [info] [jsonconfig] Config file does not have OSC mapping definitions
[2023-04-21 07:55:03.299] [info] [alsamidi] Created Alsa Midi port listen:in
[2023-04-21 07:55:03.300] [info] [alsamidi] Created Alsa Midi port read:out
[2023-04-21 07:55:03.356] [info] [osc frontend] Added osc callback /keyboard_event/main
[2023-04-21 07:55:03.356] [info] [osc frontend] Added osc callback /bypass/main
[2023-04-21 07:55:03.356] [info] [osc frontend] Added osc callback /bypass/passthrough
[2023-04-21 07:55:03.356] [info] [osc frontend] Added osc callback /program/passthrough
[2023-04-21 07:55:03.356] [info] [osc frontend] Added osc callback /bypass/gain
[2023-04-21 07:55:03.356] [info] [osc frontend] Added osc callback /program/gain
[2023-04-21 07:55:03.483] [info] [main] Starting gRPC server with address: [::]:51051
[2023-04-21 09:03:52.304] [info] [raspa audio] Closing Raspa driver.
[2023-04-21 09:03:52.910] [info] [main] Sushi exiting normally!
[2023-04-21 09:03:53.072] [info] [processor] Destroyed processor 2(gain)
[2023-04-21 09:03:53.072] [info] [processor] Destroyed processor 1(passthrough)
[2023-04-21 09:03:53.072] [info] [processor] Destroyed processor 0(main)

Except from the three annotions of missing event …cv …osc mapping definitions
there seems to be no errors, so should the bypass work with this!??

Hi RJazz. The log looks ok, as you say, missing osc and midi mappings doesn’t matter for audio.
The config file looks right too and should work for passing audio in bypass. It’s basically the same as what is already in the image as /home/mind/config_files/config_empty.json.

You mentioned in another thread that you changed the audio hat configuration using elk_system_utils. Make sure that that is set to the correct hat. It it likely correct, as sushi does start, but double check just in case.

Another control question, are you sure you have the inputs and outputs connected correctly? For the hifiberry DAC pro it should be input on the the 3.5mm jack and audio output on the rca connectors.

Thank you very much, Gustav!
Regarding the hat I am not quite sure, because I used
the DAC2 Pro, which might be slightly differ from the
DAC Pro.
I already ordered a HiFiBerry DAC+ ADC Pro,
to ensure, that I will be able to select a definetly matching hardware
for the hat.

The audio input and outputs are connected as you sayed.
(input to the 3.5mm jack).
I think,Stefanos post to my other question
could also be of importance:

Independent from that: maybe I could ask you:
on your page
there is the assembly of an “elkpi” hat displayed.
I could not find out where to order it. Do you still sell it?
In the video: Assembly of the Elk Pi Hat for Raspberry Pi - YouTube
also seems to be a big board (ElkPi hat?).
Where could I buy it?
Thank you for your help!

Yes, as Stefano pointed out in the other thread, the DAC2 Pro does not seem to have an audio input unfortunately.

The elkpi hat is discontinued, sorry. We sold out those we had.

Thank you for the information.
Meanwhile the Hifiberry works fine and I will work with it.
Thank you!

1 Like