Elk Audio OS 0.7.2 beta release (HiFiBerry support)

Hi everyone,
this is a minor update in terms of feature but it contains one that has been requested by many who simply wants to try out Elk Audio OS without having an Elk Pi shield.

We added support for a series of HiFiBerry audio hats for both Raspberry Pi 3 & 4. So now you can get started using Elk Audio OS in a very inexpensive way.

As usual, download links and instructions are on Github:

Let us know if you have any issues, we’ll be glad to answer any question.

The Elk development team

1 Like

This is great news !
Looking forward to receiving my HiFiBerry boards :slight_smile:

I have already bought HifiBerry and tried to test it.
It works well with Raspbian Buster but with a high latency (I have more than 10 ms on alsa loopback). I was counting on your elkpi system, but I haven’t been able to boot properly it so far.

I have RasperryPi 3B (v1.2 2015) with HifiBerry DAC+ ADC HW 1.2.
I flashed elkpi-audio-os-image-raspberrypi3-v0.7.2.wic on a fast SD card (I have check archive integrity and tested boot on 2 cards). After power on there are logs on screen (including “No ethernet found”) but the last log is “Starting kernel …”. After few seconds there is black screen and no signal on hdmi (display goes to sleep). I waited about 10 min - no changes. I also tried version 0.7.1 (so I can upgrade it in future to 0.7.2) but the result with 0.7.1 is the same “Starting kernel …”. I hope to test it with newer hardware but I don’t have RasperryPi 4 to test the other release version right now.

Can you help me with this? Is there any version with verbose logging at boot etc.

Hi,
We haven’t tested with RPI3B the latest v0.7.2 release but having said that it should have worked.
You can try to flash the image again and try.
Can you please send a picture of the log messages that you see on your screen ?
All the messages that you see before “Starting kernel …”
Thanks.

I have already tried to run OS with 2 different SD cards (I downloaded file twice) and the result is the same. I only wonder if my old rasp is still 100% functional (it is 2 years old and worked as Raspbian/OSMC/Kodi).
The starting boot log looks like this:

I seem to have the same problem, that the booting halts after this point.
I can’t really tell because my monitor goes into stand-by right away.

Any hints?
This is the first time I’m setting up a new Raspberry Pi with Elk.

Thank you!

One of the issues we face rarely here is the fact that it does not boot when LAN is connected. Can you see if it boots without the LAN cable attached?

LAN wasn’t connected. I’ve tried 0.7.0 now and it works.

Hello everybody,

Unter the same error …
Configuration : Rpi3b, Hifiberry, elk 0.7.2 …

Starts until Starting Kernel …

Thema, the HDMI Signal ist lost.

Downgrading to 0.7.0 dies mit seem to be an option … I Like to usw my Hifiberry, which is only supported in 0.7.2, right?

Best wishes

Jan-Torsten

Sorry for the typos … German auto correction …

Hello Elk team,

Ok, spent the whole day trying to get 0.7.2 or 0.7.1 running in a Raspberry 3b with Hifiberry.
Without success … Keeps hanging at Starting server …

0.7.0 boots out of the box.

Hifiberry is working with Raspbian.

I will do one more test on a rasberry 3b without
Hifiberry …

Best wishes

Jan-Torsten

Hello, I’m considering getting a HifiBerry DAC+ ADC Pro for experimenting meanwhile you restock Elk Pi. I’m trying to find latency info specially roundtrip. I know Elk Pi claims 1ms. What about Hifiberry? I’ll be using Hifiberry DAC+ ADC Pro with a Raspberry PI 4B 2GB.
Best
Alex

I’ve measured the roundtrip on the DAC Pro (audio in -> audio out) to be 2ms when using a buffer of 16, so the 1ms claims which I believe is only one way hold up pretty nicely :slight_smile:

It appears there’s no versions with a buffer of 8 available, which would shave off some ms fractions.
But it wouldn’t make a hughe difference anyway, so I’m satisfied.

Below is a sine wave burst measured going into the DAC Pro and coming out again. The plugin in use is the standard “no action” plugin that comes with ELK OS - don’t remember the name, but it just takes any input and routes it to the output.

Jesper, thanks for your precise answer. This seems to be very fair. I’ll give it a go.

2 Likes

Hi,
currently the HiFiBerry is configured with the ADC / DAC in high-quality mode and they add c.a. 1.3ms of latency (roundtrip).

In the next release we’ll have an option for the low-latency configuration of the codec bringing it down to 0.7ms, so you’ll be able to have a minimum analog-to-analog latency of (2 * 16) / 48000 + 0.7e-3 = 1.36ms.

On other systems we can go down to 8 samples buffer size but not on the Pi with direct codec access due to some internal FIFOs on the Broadcom SOC.

1 Like

Interesting

As fa as I recall from another post there’s an additional 4 samples to be added to the buffer size due to some internal book keeping?
Not that it matters a lot in the big picture…

Hello,

I had the same problem with the same hardware, until I install 0.7.1 (https://github.com/elk-audio/elk-pi/releases/download/0.7.1/elkpi-audio-os-image-raspberrypi3-v0.7.1.wic.bz2) then update with the 0.7.2.swu (https://github.com/elk-audio/elk-pi/releases/download/0.7.2/elkpi-update-raspberrypi3_v0.7.2.swu) with the url GUI interface (http://IP_adress:8080).

Now I struggle with my raspberry touchscreen (I want to launch sushi or other VST plugin at startup with GUI in order to play with my MIDI keyboard immediately)…

Hi everyone,
unfortunately with the current situation, none of our developers have a RPi 3B available at the moment to test.

We tested both 0.7.1 & 0.7.2 with RPi 3B+ & RPi 4B (all RAM variants).

We’ll try to get one available but it might not be immediate.

The touchscreen won’t work nicely with the RPi 3B / 3B+ as we don’t have HW GPU support for those (it is available on Pi4, though).

Best,
Stefano

I’m running the ELK Audio 0.7.2 image on RPi 4B with 2GB RAM and a HiFiBerry ADC DAC+ Pro. Everything works fine in Raspbian, but ELK doesn’t seem to recognize the HAT.

I followedthese instructions and rebooted, but running “aplay -l” gives me:

elk-pi:~$ aplay -l
aplay: device_list:272: no soundcards found...

dmesg shows the following so it seems like it took the config:

[    7.454985] audio_rtdm: hifi-berry-pro hat
[    7.466826] pcm1863-elk: codec configured
[    7.478425] pcm5122_config_codec: mode = 1
[    7.495800] pcm5122-elk: codec configured
[    7.610996] Elk hat: hifi-berry-pro
[    7.639139] audio_rtdm: driver initialized

Any ideas?

Thanks,
-Mike