Elk OS system image

I just got my Elk Pi Hat in the mail today, looks nice, thanks. I’m reading the documentation for getting it to work, specifically https://elk-audio.github.io/elk-docs/html/documents/getting_started_with_development_kit_elk_pi_hardware.html#flashing-the-elk-operating-system-image-to-the-sd-card says “Download the compressed image from the provided link” - there isn’t one at the moment though, right?

Am I correct in assuming that at the moment, one needs to compile this image yourself with the instructions offered here? https://github.com/elk-audio/elkpi-sdk

Hi @audionerd,
actually no, we haven’t publicly released the image yet.

We aimed to have this out today but there has been an SD card performance / stability issue that turned out to be much harder than we thought to fix. Early next week (Monday / Tuesday) we will release it anyway, in the worst case without the proper SD card fix we have workarounds for putting the filesystem in Read-Only mode.

If you and any others feel brave enough to test an earlier image that the closed-beta testers had, drop me a PM and I’ll send you a link to download.

Ah I see, I’ll PM you. For my general understanding though - that SDK link is for compiling the same type of system image, right? Which I’m guessing might take a long time

No, that link is for cross-compiling software to run on the image.

For example, if you have a plugin and you want to cross-compile it for the image.

Today we started pushing some on the core Elk repositories to Github (SUSHI, TWINE, RASPA), next week we will publish everything else including the Yocto / OpenEmbedded layers which are what you need to build an image from scratch.

And yes, compiling the full image takes quite some time :wink:

1 Like

Noticed this post while probing around. In a separate thread from what I am having problems with, I have had to re flash my ssd card 3 times today because , I donno, corrupt something even though I’m sudo poweroff religiously. What were the ssd stability issues and might I be running up against them?

Hi @ScreenBurn,
which version are using?

The SD card issues were all pre-public release, so if you have 0.6.x you should be fine in this regard.

I’d reccomend these things:

  1. Use a good brand of SD card, as it is also recommended in any other RPi distro. Samsung & Sandisk seem to be universally considered high quality.
  2. You can mount the entirely rootfs in read-only using the elk_system_utils script and keep all of your work in /udata. In this way, you should not have any issue in corruption of the image itself. You can temporarily mount the rootfs in RW with the same script if you need to do quick changes.


1 Like

@screenburn - I used balenaEtcher which has worked well in the past for an error free flashing process and had zero issues with the ELK. If you haven’t, give it a shot.

1 Like

I started moving slower and more deliberately when things stopped working. And switched back to using sudo shutdown -h now and my troubles haven’t resurfaced. I’ve noticed shutdown times on my pi are a bit longer than usual with the Elk boot image but yeah, my bad pulling plug too soon.

I like balena though. I just started using it. Was a command line dd guy up to now and it’s nice to not have to worry. Balena worked perfect from the get go.

The released images does not boot. I have a Pi 4 model B 2GB and have tried elkpi-audio-os-image-raspberrypi4-64_v0.9.0.wic and elkpi-audio-os-image-raspberrypi3-v0.7.2. The error shown on the screen is: start4.elf is not compatible. This board requires newer software.
Any suggestions in what I should do next?

Hi @ftiong,
the 0.7.2 will not work for your Pi4 as it is a Pi3 image.

But the 0.9.0 Pi4-64bit should work even on recent Pi4 - previously we had issues with outdated RPi firmware.

Could you check what is the filesystem layout on your SD card? Just to verify that the partitions are properly there after the initial flash.

Thank you for your help. That was a typo – I meant to say I have used pi4-v0.72.wic. Anyway, after examining the file structure of the sd card on a Linux machine it was found that there was nothing wrong. Then I put it back in the Pi and it just booted up.
Thank you.