Error reading config file, invalid file

I’m having problems running the Sushi appimage in my Linux VM. It seems as though any config file that I select gives the error: Error reading config file, invalid file.

I had been using the 0.9.0 image, but I’ve also tried 0.9.1.

The /tmp/sushi.log file says this:
[2020-03-08 14:05:37.675] [error] [jsonconfig] Invalid file passed to JsonConfigurator elk-examples-master/mda_jx10_vst2/modified2-config_play_vst2.json

I’ve tried editing the file to include more or less information, but always get this error.

Any suggestions?

  • Rick Cohen

Hi Rick. The message “Invalid file” points to the path to the file being wrong, or a permission issue so that the file can’t be read. It has nothing to to with the contents of the file, this is when Sushi is trying to open the file.

From your log it looks like you’re passing “elk-examples-master/mda_jx10_vst2/modified2-config_play_vst2.json” to Sushi. Have you tried passing either a full absolute path to Sushi, or prefixing the path with “./” so it starts from the current directory, if that’s where you’re launching sushi from?

Hello Gustav,

Thanks for your help.

As you had probably guessed, I am referring to this page for instructions on using sushi in my Linux VM:

The command line example for launching sushi shows an absolute path for the config file. I think it would be a good idea to say explicitly the requirements for that path, on the website. I tested an absolute path and a relative path beginning with “./”. The absolute path was accepted, the relative path was not.

It would also be a good idea to discuss the location and purpose of the sushi log file on this page.

Using the mda jx10 vst3 example, I’ve now got a working example on the Linux VM.


  • Rick Cohen
1 Like

Great that you got to work! Good point though, we should probably be more explicit on the use of an absolute path to the config file.

The absolute path is not a requirement of SUSHI per-se but when you are using the AppImage.