Getting the AppImage to work

Hi,
I’m using MX Linux and tried running the AppImage.
I’m getting an error and am not very familiar with AppImages.
Was hoping I could get some advice:

$ ./Sushi-x86_64_0.11.0.AppImage 
sushi: error while loading shared libraries: libcares.so.2: cannot open shared object file: No such file or directory

I have not personally used MX Linux, but the website says its based on Debian Stable so the following should work.
libcares.so.2 is provided by the libc-ares2 package, it can be installed by running “sudo apt install libc-ares2” in a terminal.

3 Likes

Thanks for the reply.
I tried building it and installing it, per the website, but that didn’t go well. I think I’m missing a step with PATH variables or something.
I’m guessing that using apt will handle that for me?

Unless you need to build sushi from source for some specific reason, i would recommend you don’t try building from source since it requires the same libraries as the AppImage build while also requiring the *-dev packages and the necessary build tools, as well as being a lot more complicated.
You also seem to have a misconception about what apt does, “apt provides a high-level commandline interface for the package management system” and (among other things) allows you to install packages, in your original posts error it is essentially saying “i need the libcares.so.2 library file, but the file does not exist” the “sudo apt install libc-ares2” command installs the libc-ares2 package which contains the libcares.so.2 library file.
After installing the libc-ares2 package you will probably get other missing library errors, i find the easiest way to find the right package is to copy the missing library e.g “libcares.so.2” and go to Debian Packages Search paste it into “Search the contents of packages” set Display: to “packages that contain files whose names contain the keyword”, Architecture: to “amd64” and hit search, this should show the package that contains the library file, you can also use the “apt-file” command e.g “apt-file search libcares.so.2”.
You’ll also want to install the “jackd2” package, the “qjackctl” package is also very useful.
I’m also going to try installing MX Linux in virtualbox and get sushi working tomorrow.
Good Luck.

I tried installing MX Linux in virtualbox, but I was unable to get the sound to work, so I thought I’d share how I get sushi running on my system (Linux Mint 19.1).
In order to get any sound in or out of sushi, jack must be installed and running, here’s an introduction to jack. Demystifying JACK – A Beginners Guide to Getting Started with JACK
Quick disclaimer, I don’t have a whole lot of experience with jack, and I installed and configured it 3+ years ago, so you may need to do some tweaking on your end.
I’m going to use the example of loading the jx10 lv2 plugin using this config.
First install jack and qjackctl with “sudo apt install jackd2 qjackctl” in a terminal, or use a graphical pakage manger like Synaptic.
In order to use the jx10 plugin the “mda-lv2” package which contains the plugin must be installed, also if you don’t have a MIDI keyboard available, you can install the “vmpk” package which provides a virtual MIDI piano keyboard.
You may notice that when starting jack that all your other programs lose sound, this is because only one sound server can be attached to your sound card at once, (the default being PulseAudio) to get pulse audio to automatically route sound to jack you can try installing the “pulseaudio-module-jack” package and enabling “D-Bus interface” and “JACK D-Bus interface” in QjackCtl>Setup>Misc, You may need to restart your system for this to work.
Now that every thing’s installed let’s begin.
First open QjackCtl and hit start, then open a terminal in the directory with sushi, and run this command “LV2_PATH=/usr/lib/lv2/ ./Sushi-x86_64_0.11.0.AppImage -j --connect-ports -c /home/jonathan/Desktop/sushi/config_play_lv2_jx10.json” I think a short description of this command is important.
“LV2_Path=/usr/lib/lv2/” This environment variable tells sushi where to find lv2 plugins, if your not loading any lv2 plugins you can omit this.
“-j” Tells sushi to use jack.
“–connect-ports” Tells sushi to automatically connect it’s audio inputs/outputs to jack’s input/outputs.
“-c” The path to your sushi configuration file, this will be unique to where your config file is on your system, note that this must be an Absolute Path otherwise sushi will fail with a vague error message.
Now either connect your MIDI keyboard or start VMPK.
Then go back to QjackCtl and click Connect, go to the ALSA tab and on the left side select your keyboard and on the right select sushi, then hit Connect.
You should now be able to play the jx10 synth with your keyboard.

I hope this post helps, if you have any other questions just ask.

2 Likes

Thanks for the replies!
Installing Mint now. Will give it a try.
It was almost 20 years ago, but I used to play with JACKLab, when that was a thing…