Problem persisting WiFi settings on Elk Pi

I recently received my Elk RPi devkit and today set out to get it up and running. The whole process was very simple and smooth, and I’ve successfully gotten to the point of running the included example synth.

However, I’ve had some problems in persisting the settings for WiFi. I’ve followed in the instructions I found on the web, using connmanctl. I can successfully connect to my WiFi network, I get an IP address, and everything seems fine, but when I reboot, the connection does not come up automatically. It seems my WiFi is remembered though, as if I run connmanctl again and connect to my WiFi, I no longer need to give my password.

Also, it seems the SSH key of the Pi gets regenerated with every boot, as when I try to connect using SSH again after reboot (this is over fixed Ethernet of course, as WiFi won’t come up), SSH complains that the key has changed, and I have to remove it from my known_hosts file before I can connect again.

I will continue to dig around and see if I can sort this out, but any help would be greatly appreciated!

Other that this little annoyance, the Elk Pi seems awesome, and I really look forward to start programming it!



Hi @superjudge,
the SSH key regeneration is a known issue with a workaround, see here on Github:

(we’re releasing soon an update that includes this among other fixes and new stuff).

For the WiFi, have you tried to see if it just takes a while after boot? I remember some other users had similar issues but on most cases and even in our setups it seems to work.

1 Like

Hello there.

I know this is an old thread… but I just came across the same issue.

I have a Pi4, with Hifiberry DAC+ADC, and eveything goes fine.

But… sometimes, when booting the Pi, Wifi just doesn´t connect. Sometimes, rebooting solves the issue and it connects fine. Maybe I poweroff and start again, and it´s fine… but maybe not. You never know when it´s going to work ok or when you´ll need to bring back the keyboard and display to try to fix it.

The first times, I just tried unplugging cables from the Hifiberry and rebooting… and it worked a couple times, so I though that some kind of static electricity being present in the board or whatever (don´t actually know what I´m speaking about, really), but later I found that cables are not guilty.

The only thing that seems to work is to connmactl again, make all the steps (agent on, scan, services…) except that, when I try to connect wifi_xxx it just throws errors. But rebooting at this point causes the wifi to connect again.

I´m a little lost, and it worries me because not being able to connect the Pi via wifi kills all the utility for me, since I wouldn´t be able to SSH and control plugins with a GUI from a PC/phone.

Any new on this problem? Thank you!