Resizing /udata partition

Hi everyone,

I have a 32GB SD card but when I flash Elk Audio OS into it I only get a 2GB /udata partition. I’ve trying to grow the partition to use the remaining ~25GB but I have not been able to do it. I tried to follow steps in here How to Resize a Partition using fdisk - Red Hat Customer Portal, but when reaching step 8 I can’t do it because it says the partition is still in use. Any pointers about how should I do that?



Pinging stefano here @Stefano :slight_smile:

Hi @frederic. Unfortunately I can’t answer your question but I figured I’d help you get attention by pinging @Sharan and @Nitin since they are the low-level wizards of Elk :slight_smile:

1 Like

Hi @frederic, if it’s just the udata partition that you want to extend upto the end of the SD card then it should be fairly simple.
Have you tried to unmount udata and then extend the P4 partition ?

I usually use this utility called parted to do it.
Let me know how it goes.


Yes that is what I tried, but not using “parted”. I’ll try with this utility as using the “usual” steps for resizing partitions that I found did not work for me. thanks!

Hmm, I just tried and parted is not installed in the elk audio os distribution. How do I install it? The usual package managers don’t seem to be available… @Nitin

Oh that’s unexpected. I thought we have installed parted in the image. You can use parted or gparted on any Linux machine and extend the sdcard’s last partition. That will also do the job.

maybe in newer versions of the sdk, i’m using 0.9 I think, i could update. but I’ll try doing it from another machine, sounds good!