Sushi not on pi4

Hi everyone,

First of all I am a complete noob with linux, but im trying to get into it with the Elk Audio OS.

But I am running on an issue very early on when trying to run sushi.
Im following the guide from here step 3.
but when i type the command, it returns:

[1] 282
elk-pi:~$ cat: /sys/module/audio_rtdm/parameters/audio_buffer_size: No such file or directory
/usr/bin/sushi: line 7: exec: sushi_b: not found

im runnig the latest release of elk_os on a raspberry pi4 2GB

I’m not sure where to go next, does anyone know where to find a solution to this?


Are you running on Elk PI or HIfi Berry hat ?
I guess you are running on a Hifi Berry hat but you haven’t set the right hat using “elk_system_utils”. By default Elk Audio OS is configured to be run on Elk Pi hat, so if you are using a Hifi Berry hat then you need to change the audio_hat appropriately using the command “elk_system_utils”. You can find the documentation here.

Hi Nitin,

I am starting to see a problem here, So do you need either the elk pi (dev kit hat) or the HiFiBerryHat to get it to work properly? I am just having the raspberry pi4 alone without any other hardware.

If this is true, Which one would you recommend me:
I am trying to build a guitar amplifier with the effects/vst’s running on the pi.

thanks for your help,

Hi @wabbywouter,
yes you need one supported Hardware HAT to run the system, the question seems to be very popular, see these thread too:

Raspberry pi with builtin audio

1 Like

I just got a HiFiBerry DAC+ ADC PRO for my Pi and it works really well.

1 Like

Hi there!
I’m just writing here because I googled the error I’m getting after the last 0.9.0 update (I used the swu to update my Pi4) and I found this topic.
I’m using a DAC+ ADC PRO and I already set my hat as described, but the error is still there.

In addition to that, I noticed the elk_system_utils is failing to update the config.

sed: can’t read /udata/.elk-system/elk-system.conf: No such file or directory
Using audio hat hifiberry-dac-plus-adc-pro. Please power cycle for changes to take effect…
Note! This is persistent across boot cycles but not after software update.

I tried to create an empty elk-system.conf file and the error is gone, but I still can’t run sushi, also my elk-system.conf seems to be empty even after I try to set my DAC+ ADC PRO as hat.

Is there something I’m missing here?

EDIT:: I also tried with a fresh os install on my sd card. The settings are now correctly stored, but I can’t run sushi:

cat: /sys/module/audio_rtdm/parameters/audio_buffer_size: No such file or directory
/usr/bin/sushi: line 7: exec: sushi_b: not found

Actually, the audio_rtdm folder can’t be found in the /sys/module

Thank you so much

HI @lucanisi,

Thanks for pointing this bug in elk_system_utils. I have fixed this issue and we ll replace the image on github with the correct one. Meanwhile if you want to use the image that you already have, you need to edit the load-drivers script present here /usr/bin.
You just need to replace the audio hat name as AUDIO_HAT="hifi-berry-pro" .

It should be good enough. Anyways, the new image should be uploaded tomorrow.


Thank you so much @Nitin
About the audio_rtdm folder missing in /sys/module is there something I need to do in this scenario?
Unfortunately sushi still doesn’t run :frowning_face: even with a fresh install

If you change the AUDIO_HAT to “hifi-berry-pro” that should solve the problem.
Just replace AUDIO_HAT="elk-pi" to AUDIO_HAT="hifi-berry-pro"
You need to restart the board.

Yeah I did @Nitin but with no success unfortunately.
I tried to run the script just to check what was going wrong and here is the outcome:

modprobe: ERROR: could not insert ‘audio_rtdm’: Operation not permitted
audio_rtdm failed

I guess the driver is missing or something, anyway I’ll wait for the updated image to do a fresh install :slight_smile:
Thank you!

HI @lucanisi,
thanks for pointing out the issue - we have just updated the SWU & images, there was a clear fix that we didn’t identify given the status of our testing boards.

It should be working now. If you don’t want to update, it should be possible to modify the audio hat by directly editing /usr/bin/load-drivers.

Hi @Stefano
unfortunately even manually editing /usr/bin/load-drivers and rebooting the Pi it doesn’t fix the sushi issue.

I still can’t find the /sys/module/audio_rtdm folder and when I try to run sushi here is the outcome:

cat: /sys/module/audio_rtdm/parameters/audio_buffer_size: No such file or directory
/usr/bin/sushi: line 7: exec: sushi_b: not found

Anyway, I’ll try to flash the whole OS again.

EDIT: A fresh install fixed my issue

Thank you :slight_smile:

1 Like