Sushi won't stay running

I’d like to start this off by saying I have next to no experience on forums so if I’m doing anything wrong please let me know.

I received a Pi 4 for Christmas and want to run Elk Audio OS, latest release from github, no hats or anything. Installs fine, wifi works great.

Here’s the problem: I cannot get sushi to work on the pi. If I run the example command given (as given) on the documents page I get an error that says Error initializing frontend, check logs for details. Log says [error] [raspa audio] Error opening RASPA: Raspa: External micro-controller not responding. If I run that same command with sudo, I get no error but also nothing else. Note that this is under the mind user account. Here’s the kicker: sushi may be running but if I try to initialize a midi controller to test using aconnect -l, it lists my devices but ends with Stopped and then the command to launch the plugin. The final issue is if I take the & off the end of the command (just to see what happens), it gives the same error about the frontend and with sudo I get sushi: error while loading shared libraries: libcobalt.so.2: cannot open shared object file: No such file or directory. Thank you for bearing with my noob self and I really hope it’s something painfully obvious.

I just had the exact same issue. I don’t know where the file is supposed to come from. libcobalt.so.2

Looks like some of the supplied examples may not have all the required files to work.

Note, I was trying different examples on a Pi Hat + Blackboard setup.

I tried some other examples under /udata/elk-examples/controller-something and did not get this error.

Can you tell us what the exact sushi command was, which script you were trying to run, etc. ??

The command used was $ sushi -r --multicore-processing=2 -c ~/config_files/mda-vst3-configs/config_mda_synth.json & to run the mda jx10 synth plugin. The only thing in the udata folder for me is lost+found.

I see. Well it just means you haven’t installed the examples yet. Sorry I can’t answer your question, just wanted to let you know that at least for me, some of the examples did work and I also saw this problem.

Thanks for the help anyway. I’m going to try and install the examples and go from there.

1 Like

Running sushi with the RASPA frontend (-r flag in sushi command) requires a compatible audio hat (elkpi, hifi-berry etc.) and trying to run without the hat is most likely the reason for the error you’re seeing here. You could probably still run sushi with the dummy frontend or the offline frontend but you won’t get realtime audio with Elk on a RPi unless you use one of the supported hats.

2 Likes

Got it. The documentation seems to imply that you don’t need the hat but it makes more sense that you would need one, considering Pis aren’t known for HD audio. And now that I think about it, that explains the micro-controller not responding error in the log, as there isn’t a micro-controller to respond. Thanks for the help and saving me a lot of time.

No worries :slight_smile: would you mind telling me what in the documentation implied that you could run without a hat so I can look at rephrasing it to avoid future confusion?

1 Like

“If you are not using these, you can skip to step 3, and run Sushi” at least to me implies that you don’t need the hat. Step 3 also does not mention anything specific about running without hats so I just figured the hats were a recommended add-on.

1 Like

Thank you for pointing it out! It does indeed seem to imply that you can run without a hat. I think earlier in that section it mentions that you should follow another getting started guide first which possibly mentions the required presence of some kind of hat. But we should definitely make this a lot clearer in this section! :sweat_smile:

1 Like

Thanks again for all of your help! This is an awesome project and I can’t wait to try again once I get the required hardware.